Slant *        6        Forum
Home Home Home
The Place to Go for Slant Six Info!
Click here to help support the Slant Six Forum upgrade!
It is currently Sun Sep 22, 2019 9:05 am

All times are UTC-07:00




Post new topic  Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Wed Jan 21, 2015 6:26 pm 
Offline
4 BBL ''Hyper-Pak''

Joined: Thu Jul 12, 2012 5:57 pm
Posts: 25
Location: Georgia
Car Model*:
Ok I was having stumbling and part throttle acceleration problems on my 65 Valiant. Haven't been doing much to it in the past several weeks because it stays outside and it's been too cold and dark when I get home. Got a break in temp today and a day off so I took off my less than 2 month old reman Holley 1920 List #3054. It has the float bumper spring in it but no baffle. I've since scored a junky Holley 1920 off of Ebay with a factory float bowl baffle in it. So basically I paid $50 for a junky Holley 1920 as the top of the casting is broken. I noticed in my reman Holley has probably an original Holley float inside. So maybe a new float? What else do I need to check on this reman carb while I've got it apart so that the stumbling on part throttle acceleration will go away? The engine started up easy had good fuel pressure and 16-17hg of vacuum at idle in park. Couldn't get anymore mixture adjustment out of it. So what can I check on the carb before putting it back together so I can rule out a carb issue? I've only taken off the bowl I haven't further disassembled it.

_________________
1965 Plymouth Valiant 200 4DR 2.8L 170CID
1973 Dodge Charger 6.6L 400CID
1986 Plymouth Reliant SE Wagon 2.2L 135CID


Top
   
 Post subject:
PostPosted: Thu Jan 22, 2015 1:38 pm 
Offline
Turbo Slant 6

Joined: Sun Jun 01, 2014 10:27 am
Posts: 548
Location: Waynesboro VA
Car Model*:
I would be looking at accelerator pump not being right and/or float level low.

- Accelerator pump diaphragm and accel pump cam on the outside that pushes on the pump rod
- Accelerator check valve ball not seating or dirty; check out the 1920 video's at Mikes Carburetors or some of the Holley links here to see how this works
- Float set with the bowl upside down and dry, and also check wet float level; procedure can be described or found in early FSM's
- New 12.7 gram floats available at Mike's Carburetors
- New carb base gakset and check for any vacuum leaks in manifold or power brake booster


Top
   
 Post subject:
PostPosted: Thu Jan 22, 2015 4:05 pm 
Offline
TBI Slant 6
User avatar

Joined: Thu Jan 24, 2013 3:39 pm
Posts: 174
Location: Houston, TX
Car Model*:
Stumbling: I had same problem, never got fixed until I bought an old, never used carb.

However, for the remanufactured, follow as suggested above. Some comments:

Check here for info on the 1920:

http://www.slantsix.org/forum/viewtopic ... sc&start=0

and

http://www.slantsix.org/forum/viewtopic.php?t=55801

READ THE 1920 service manual in the first link completely before keep going.

Acc pump diaphragm and pump cam: check if they work properly and w/o leaks (to have access to the diaphragm you need to remove the economizer block, that might damage the diaphragm. You might want to have a rebuilding kit at hand). The cam can be graduated to squirt more or less fuel when accelerating (3 holes to connect the link between the cam and the pump (page 12 fig 2), too rich might cause hesitation, too low will be lazy.

New float: buy the spring too, float-spring need to match. I might take a picture to show you the difference in springs (to know which ones you have).

Also to get the proper liquid level in the bowl, follow the manual instructions in the first link (pg 16). Level it outside, then install the carb back, start the engine and check level while running (you mightl need to accelerate the engine a little because the loss of vacuum when opening the bowl in the economizer, use the curb idle screw. Gas should not spill, but as always with gasoline, be carefull and thougtfull

Check that all vacuum tubes are connected properly (vacuum to distributor and choke, only), and check the choke operates (opens when accelerating the engine). Check carb vent closes when accelerating (hole at the top of the bowl)


Three other things:

- butterfly shaft should not have too much play/be worn, or air will get in (you're getting good vacuum, so that might be ok). Use carefully a carb cleaner spray (check that does not have weird chemical like chlorine) and spray at shaft bushes to see if engine accelerates while running the engine

- Economizer-powervalve gone: you might want to swap the economizer-powervalve assembly of the broken carb to the one you have and test. These things can get damaged beyond repair after long time.

- Nozzle: check the gas nozzle in the economizer. I guess should be a 54 or 56, don't remember now but in that range, depends on the year. IDK if changing nozzles might help.

Carbs can get damaged beyond repair with time. Check what you have, hopefully you can fix it.



PD: By the way, did you checked valve lash? That might help too...

_________________
/6 Dodge Charger 69
Image...there's nothing like using the "Search" link above to solve most of your problems...


Top
   
 Post subject:
PostPosted: Fri Jan 23, 2015 6:52 pm 
Offline
TBI Slant 6
User avatar

Joined: Thu Jan 24, 2013 3:39 pm
Posts: 174
Location: Houston, TX
Car Model*:
Here is the spring picture:

https://onedrive.live.com/?cid=361890a5 ... Nf7D_M&v=3

The one to the right is from Mike's Carb, the one to the left is the old one. However, I was testing both with a dead weight, and they behaved like similar. Not sure if they are really different (however, the floats are different. Something you might want to try too is setting the old float for a lower liquid height as suggested by Mike,s website:

http://www.carburetor-parts.com/Holley-1920_ep_329.html

then click on floats.).

About the nozzle I should have said between 62 to 65. You can check discussions about nozzle sizes in the search link.

_________________
/6 Dodge Charger 69

Image...there's nothing like using the "Search" link above to solve most of your problems...


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 4 posts ] 

All times are UTC-07:00


Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Limited